Reports of Payment Issues
Incident Report for SageSure Agent Portal
Resolved
This incident has been resolved.
Posted Feb 11, 2020 - 09:47 EST
Monitoring
Reports of payment issues have subsided and we are monitoring the payments system.
Posted Feb 11, 2020 - 08:38 EST
Update
We are continuing to investigate an error some users are experiencing when they click "Make Payment". Some users have been able to workaround this issue by clearing their browser cache and restarting their browser session.

If you are impacted by this error, please call Policy Services at 1-877-304-4785 to complete the payment.
Posted Feb 10, 2020 - 15:48 EST
Update
We are continuing to investigate this issue.
Posted Feb 10, 2020 - 10:20 EST
Investigating
We are currently investigating reports of issues when attempting to make a payment.
Posted Feb 10, 2020 - 09:34 EST