Intermittent Payment Disruption
Incident Report for SageSure Agent Portal
Resolved
This incident has been resolved.
Posted Apr 05, 2023 - 14:41 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 05, 2023 - 13:25 EDT
Investigating
A third-party service for our system is experiencing an intermittent disruption which affects submitting payments. If you receive an error do not retry submission.
Posted Apr 05, 2023 - 13:24 EDT