Address Validation Incident
Incident Report for SageSure Agent Portal
Resolved
This incident has been resolved.
Posted May 31, 2022 - 23:35 EDT
Update
Our vendor has been identified the issue and is currently working on a fix.
Posted May 31, 2022 - 21:48 EDT
Identified
Our vendor has been identified the issue and is currently working on a fix.
Posted May 31, 2022 - 19:43 EDT
Investigating
We are currently investigating issues with Address Validation. At this time, Address Validation attempts are failing. Additionally, protection class and distance to fire department may be blank on new quotes. We are working to restore this service now.
Posted May 31, 2022 - 18:28 EDT